Nedir ne işe yarar ?

QualityArmory, temel oyunu etkilemeden Minecraft’a silahlar ekler.

Oyunda silahları eklemenize, kullanmanıza, arkadaşlarınızla bu silahlarla kapışmanızı sağlar.

Özellikleri Nedir?

  • 80’den fazla Silah ve 7’den fazla Cephane türü eklenir.
  • Oyundaki mevcut eşyaları silmez & değiştirmez.
  • Dahili kaynak paketi dağıtıcısı; Oyuncular, sunucu kaynak paketinizi değiştirmenize gerek kalmadan silahları görecekler.
  • Diğer eklentilerin silah eklemesine izin veren bir API içermektedir.
  • 1.9X – 1.16X Arası sürümleri destekler.
  • 1.8X kısmi desteğe sahip – Bu güncellemenin dokuları işleme şekli nedeniyle, şu anda sadece 15 silah mevcut.
  • Eğer LightAPI yüklenir, silahlar namlusu gerçekçi ateş eder gibi olacaktır.
  • [İsteğe bağlı] Etkin silah dayanıklılığı (config.yml’de EnableWeaponDurability)
  • Dükkan ve işçiliği masasında inşa edilmiştir.
  • Tamamen Yapılandırılabilir. (İşte tüm yapılandırılabilir seçenekler için tıklayınız.)

Kaynak Paketi Hakkında?

  • Kaynak paketi eklentiye dahildir ve gerekirse yapılandırmada yapılandırılabilir.
  • Varsayılan olarak, kaynak paketi, oynatıcı bir /qa komutu kullandığında veya özel bir öğeyle etkileşime girdiğinde gönderilir. 
  • Bu değerler yapılandırmada yapılandırılabilir; Kaynak paketi devre dışı bırakılabilir (useDefaultResourcepack), oyuncu katıldığında gönderilecek şekilde ayarlanabilir (sendOnJoin) veya özel bir kaynak paketiyle (DefaultResourcepackOverride’ı true olarak ayarlayarak (QA bunun özel bir url’sini bilmesi için) ve DefaultResourcepack ile geçersiz kılınabilir.)

Crackshot Desteği Varmıdır?

  • QualityArmory artık crackshot silah dönüşümlerini destekliyor.
  • Crackshot için silah yapılandırmalarını /newguns/ dizinine bırakın ve QA’nın silahları dönüştürmesi için yeniden yükleyin.
  • Tüm crackshot silahları artık QA için karşılık gelen bir .yml dosyasına sahip olacak.

ViaVersion Desteği Varmıdır?

1.8X öğe başına birden fazla modele izin vermediğinden, bu güncelleme için her silahın bir öğeyi değiştirmesi gerekir. Bunu aşmak için, 1.8 algılanırsa veya sunucu ViaVersion çalıştırırsa, 1.8 ile çalışacak yeni bir sistem uygulanır. Ancak, bu mevcut silah miktarını sınırlar.

Geçiş söz konusu olduğunda, varsayılan olarak, sistem 1.9X+ kullanıcının tüm silahları görmesine izin veren, ancak 1.8 oyuncu tarafından kullanılan silahları sınırlayan yerindedir. Bazı durumlarda, 1.8 oyuncu 1.9+ silahın tümü için yalnızca tek bir model görür veya silah, 1.8 oyuncunun görebileceği/kullanabileceği bir öğeye dönüştürülebilir. 

1.8 silahın tüm sürümlerde tutarlı olmasını istiyorsanız, yapılandırmada “ManuallyOverrideTo_1_8_systems” öğesini true olarak ayarlayın ve /newguns/, /armor/, /ammo/, /misc/ ve /attachments/ dizinlerini silin.

Sunucu İçerisindeki Komutlar?

  • /QA <Gun/Ammo> silah verir, oyuncuya “qualityarmory.give” izni varsa öğeyi verir.
  • /QA craft , oyuncuların “qualityarmory.craft” izinleri varsa silah üretebilmelerini sağlar.
  • /QA shop , oyuncuların “qualityarmory.shop” izinleri varsa silah dükkanı açmalarına izin verir.
  • /QA reload, eklentinin tüm değerlerini yeniden yükler.

Nasıl Silah Yapabiliriz?

  • Özel silahlar oluşturmak Crackshot kadar kolaydır. 
  • Yeni silahların nasıl oluşturulacağını öğrenmek için BURADA Wiki’yi ziyaret edin.
  • Wiki’nin tamamını okumak için (BURAYA TIKLAYIN)

Çakışmalar Olur mu?

EssentialsX ile, ışınlandıktan sonra oyuncuları zarar görmez hale getirme değeri olduğu bilinen bir çakışma var.

Bununla birlikte, vurulan oyuncuların hasarını da durdurur.

Bunu düzeltmek için EssentialsX yapılandırmasında teleport_vulnerability‘yi 4’ten 0’a değiştirin

QualityArmory’yi Destekleyen Eklentiler?

QualityArmory Yazılımının Bağlı Olduğu Eklentiler?

  • LightAPI : Silah kullanıldığında namlu çıkışları için kullanılır. [Gerekli değil]
  • Taraflar : Dost ateşini devre dışı bırakmak için kullanılır. [Gerekli değil]
  • ProtocolLib : Silahlar kullanıldığında oyuncuyu geri tepme için sorunsuz bir şekilde değiştirmek için kullanılır.
  • Vault : Silah dükkanı için kullanılır. [Gerekli değil]
  • ViaVersion : QuialityArmory, farklı minecraft güncellemelerinden oyuncuların aynı modelleri görmelerini sağlayan ViaVersion desteğine sahiptir. [Gerekli değil]
  • ItemBridge : Bu eklenti, diğer eklentilerin, o eklentiyi destekliyorlarsa QualityArmory öğelerine erişmesine izin verir.

Oyuncular İçin Gerekli İzinler?

  • qualityarmory.*
    • Inherits qualityarmory.admin
  • qualityarmory.admin
    • qualityarmory.give
    • qualityarmory.create
    • qualityarmory.reload
    • qualityarmory.createnewitem
    • qualityarmory.getmaterialused
    • qualityarmory.debugmessages
    • qualityarmory.getopengunslot
    • Inherits quailityarmory.default
  • qualityarmory.default
    • qualityarmory.craft
    • qualityarmory.shop
    • qualityarmory.usegun

API Hakkında Detaylı Bilgi?

Eklentinin Çalışması İçin Ne Gerekli?

  • Bu eklentiyi plugins klasörünüze bırakın.
  • Kendi dünyanıza ulaşmanızı sağlayacak bir eklenti oluşturun.
  • Sunucunuzu yeniden başlatın.

QualityArmory Plugini Nasıl İndirilir?

Buraya tıklayarak plugini indirebilirsiniz.

QualityArmory Hakkında Görseller:

Konuyu nasıl buldun?
0
0
0
0
0

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir